PL/SQL package SYS.DBMS_BACKUP_RESTORE version 19.03.00.00 in TARGET database is not current after upgrade

Hi there,

Yesterday I upgraded a 19.3 database to 19.6 on Windows 10 Pro and after upgrade Rman starts to give two warnings:

PL/SQL package SYS.DBMS_BACKUP_RESTORE version 19.03.00.00 in TARGET database is not current

PL/SQL package SYS.DBMS_RCVMAN version 19.03.00.00 in TARGET database is not current

this didn’t happen when I upgraded from 19.5 to 19.6. anyway if you have this problem you can simply recreate dbms_backup_restore and dbms_rcvman packages which are under the ORACLE_HOME/rdbms/admin directory.

Dbms_Backup_Restore
dbmsbkrs.sql
prvtbkrs.plb

DBMS_RCVMAN
dbmsrman.sql
prvtrmns.plb

2 thoughts on “PL/SQL package SYS.DBMS_BACKUP_RESTORE version 19.03.00.00 in TARGET database is not current after upgrade

  1. Stephan Borsodi

    Hi Mustafa
    Thanks for the hint, I had the same problem with 19.3 to 19.9 … for immediate handling you could advice your visitors with following commands and calls:

    * Dbms_Backup_Restore, in sqlplus:

    connect / as sysdba
    @?\rdbms\admin\dbmsbkrs.sql
    @?\rdbms\admin\prvtbkrs.plb

    * DBMS_RCVMAN:

    @?\rdbms\admin\dbmsrman.sql
    @?\rdbms\admin\prvtrmns.plb

    • Mustafa

      Hi Stephan,

      Thank you for your comment. It is so nice to hear from visitors 🙂

Leave a Reply to Mustafa Cancel reply

Your email address will not be published. Required fields are marked *